Váš server beží na systéme PHP verzie 5.0.3, ale WordPress4.1 vyžaduje aspoň 5.2.4.